Supported Browsers

We officially support the following browsers for use with a Store's admin area:

  • Google Chrome 7+
  • Apple Safari 4+
  • Mozilla Firefox 4+
  • Internet Explorer 9+

However, we recommend always using the latest version available.